Posts Tagged ‘configure: WARNING: You will need re2c 0.9.11 or later + json’

WARNING: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.

June 15th, 2010

I am getting this error “configure: WARNING: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.” while i tried to install json support with PHP 5.1.6

What is re2c?
re2c is a tool for writing very fast and very flexible scanners. Unlike any other such tool, re2c focuses on generating high efficient code for regular expression matching. As a result this allows a much broader range of use than any traditional lexer offers. And Last but not least re2c generates warning free code that is equal to hand-written code in terms of size, speed and quality.

I download the wget ftp://195.220.108.108/linux/dag/redhat/el4/en/x86_64/dag/RPMS/re2c-0.12.3-1.el4.rf.x86_64.rpm and installed on the server

#rpm -ivh re2c-0.12.3-1.el4.rf.x86_64.rpm
cd /tmp/json-1.2.1
./configure –with-php-config=/home/user/dev/php/bin/php-config> –with-json
make && make install
ll modules/json.so

OR

cp modules/json.so  /home/user/dev/php/lib/php/extensions/
/home/user/dev/php/bin/php -m
Edit
vim /home/user/dev/php/lib/php.ini and add extention extension=json.so

Restart apache
/home/user/dev/apache/bin/httpd -k  stop/restart/start

Thanks
Manoj


Warning: Unknown: write failed: Disk quota exceeded (122) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0